Drupal 7 Aproval of New Users Not Working.... I assume

xarzu's picture

They have: 24 posts

Joined: May 2007

I have my fresh Drupal 7 web site up and running. I am currently testing it. My first test is to try the functionality of creating a new user. I tested added myself (no, not my admin account -- a different one with a different email address). The new user's (mine) email got an alert saying that the account would be approved by the admin and further instructions and password would be sent to me.

I got the alert email also at the admin email address and I logged on and assigned the account a password and approved the account.

But the new user's email never got the notification. I also tried to find the user's email address by using the admin's privileges on the site in case I needed to deliver the message to the user by hand. But I could not find out how to do that.

Please help and advise.

Is it because the Admin account is a gmail account? Is there an issue involved with using gmail? To test this, I went into the "People" setting and I changed the email associated with the Admin. Then I ran a test of a new user. The new user got the email but the email message stated that it had come from the old gmail account. Does this mean I need to completely do a fresh install or is there some special way to change the real setting for the administrator?

Megan's picture

She has: 11,419 posts

Joined: Jun 1999

No, you don't need to do a new install. It might be because it's a gmail account. I seem to remember coming across that before.

I think the emails will appear to come from the site default email address under Configuration > Site Information .

Want to join the discussion? Create an account or log in if you already have one. Joining is fast, free and painless! We’ll even whisk you back here when you’ve finished.